MythTV.nl

Hardware en bijbehorende software(drivers ed.) => (Afstands) Bediening => Topic started by: pbtinus on 30 October 2007, 20:27:17



Title: VFD (schermpje) en microsoft MCE ir afstandbediening conflict
Post by: pbtinus on 30 October 2007, 20:27:17
Wat leuk dat ik als eerste een post mag doen in het kopje, afstandbedieningen.

mijn probleem, of laat ik maar zeggen uitdaging is het volgende:
Als ik op mijn mythdora 4.0 bakkie mijn mce ir ontvanger knoop werkt deze vlekkeloos, als ik op hetzelfde mythdora beesie mijn vfd schermpje aansluit via usb (imon drivers) werkt deze ook prima met procserv op de achtergrond draaien.
Als ik beide aansluit, je raad het al, werkt alleen de vfd en weigerd de mce ab te werken. Het zal ongetwijfeld aan de imon drivers / procserver settings liggen, maar ik kom er niet uit, iemand tips of trucs hoe ik e.e.a. aan de praat kan krijgen of wat ik moet aanpassen zodat beide usb apparaten werken ?

de mce ontvanger en de vfd worden beide appart gezien op de usb poorten, en appart benoemd, dus lijkt mij een setting probleem......

ik hoor het graag.

gr tinus


Title: Re: VFD (schermpje) en microsoft MCE ir afstandbediening conflict
Post by: Michel on 30 October 2007, 20:33:25
Hallo Tinus,

Er bestaat in LIRC ook een driver "lirc_imon" die zorgt dat LIRC ook iets met dat ding kan.
Naar wat ik vermoed is die driver eerder geladen door LIRC dan de MCE driver,
waardoor ik vermoed dat die MCE AB nu een ander device node heeft: /dev/lirc1

Geef anders eens een post met daarin het resultaat van "ls -l /dev/*lirc*",
en eventueel de output van het "dmesg" commando als _beide_ apparaten zijn aangesloten op je systeem.

Michel.



Title: Re: VFD (schermpje) en microsoft MCE ir afstandbediening conflict
Post by: pbtinus on 6 November 2007, 20:21:45
bedankt voor de reactie, een beetje een late van mijn kant, maar helaas kan ik wat minder tijd steken in het prutsen met mijn mythdora kastje als dat ik zou willen.

Maar je hebt gelijk, de ab heeft lirc1 toegewezen gekregen, deze heb ik in :
/etc/udev/rules.d/lirc.rules aangepast naar lirc1 ipv lirc0

KERNEL=="lirc[0-9]*",   NAME="lirc%n"
KERNEL=="lirc1",                SYMLINK="lirc"

dus probleem opgelost, en ik had het achteraf zelf kunnen bedenken.......... maar ach.

dank is groot, en topic kan gesloten worden.

gr tinus